HTC Will Cut Apps to Fit Android 2.3 on Desire

Posted by at 10:52 am on June 16, 2011

HTC in a fresh Facebook statement said that it would have to make compromises to fit the Desire’s upgrade to Android 2.3. Memory was still a problem and would push the company to “cut select apps” to make it fit. The phone builder didn’t say which but implied it would be pruning some of the less vital HTC Sense apps rather than anything from Google.

The company had initially said it wouldn’t upgrade at all as it claimed it couldn’t fit both HTC Sense and Android 2.3 on the Desire at the same time. A public outcry led it to eventually change its mind.

Leave a Reply

Sign Up For Our Newsletter

Sign up to receive breaking news
as well as receive other site updates

Enter your Email


Preview | Powered by FeedBlitz

Log in

Copyright © 2008 - 2020 · StreetCorner Media , LLC· All Rights Reserved ·